Extension Updates

Podcast Manager 2.0.0 Released

Podcast Manager 2.0 Stable has been released today and is now available for download.  This is the first release of the 2.0 series and has undergone numerous changes to add user requested features, fix outstanding bugs, and overall improve the user experience in all interactions with the extension package.  Additionally, this release ONLY supports Joomla! 2.5.4.

Changes since 1.8

Podcast Manager 2.0 has been in development for about nine months and greatly improves the existing features as well as adds additional features and compatibility with the core Joomla! system.  The change list includes:

  • New Features
    • Adds multi-database compatibility (can be installed on SQL Server and PostgreSQL as well as MySQL)
    • Improved use of Joomla! ACL, now able to assign permissions at component and feed level, the perfect solution for sites with multiple feeds
    • Improved component router for better SEF URLs
    • Default media player settings can be overridden by the content plugin when used within articles; this includes the type of media player and the height and width of the player
    • External libraries updated to latest versions
    • Improved user notification of errors
    • Added option for a boilerplate text for podcasts within a feed
    • Smart Search plugins added
    • Adds a new plugin type to customize the default media path (distributed plugin appends logged in username when enabled)
    • MediaElement.JS has replaced all other media players
    • Feed Listing module can now display the media player
  • Miscellaneous Changes
    • Support for Minima template has been dropped due to developer having temporarily halted development
    • Most front end errors are no longer displayed to users but are logged in the error log file if logging is enabled
    • MediaElement.JS has a requirement to use jQuery; an option has been added to the content plugin to disable loading jQuery with the content plugin (this is useful if your template, for example, also uses jQuery and to help prevent version conflicts)
    • The upgrade script ensures that all outdated files are removed during the 1.8 to 2.0 upgrade
    • Brazilian Portuguese (pt-BR) translation updated
  • Bug Fixes
    • Fixes the often reported RSS validation issues

Supports only Joomla! 2.5.4

This release of Podcast Manager is only available for Joomla! 2.5.4.  Earlier versions of Joomla!, including earlier releases in the 2.5 series, are not supported due to the use of new API features and security vulnerabilities affecting early 2.5 releases.

Upgrade from Previous Releases

Users of Podcast Manager 1.x who are running Joomla! 2.5.4 will be able to upgrade immediately using either the Live Update button within the backend control panel or using Joomla's built in update system.

Need Additional Support?

Documentation about Podcast Manager is available on this site in the Podcast Manager section.  This area includes information about the suite, a description of the various configuration options, a method to subscribe for e-mail updates, and tutorials on various functions.  If you don't see something here that you think would be beneficial for all users, feel free to Contact Me with your suggestion.

Future Development

Now that the 2.0 series is stable, work for new features to be implemented in the 2.1 series can begin.  Although there are no plans at this time for the feature set, users can request features using the Issue Tracker on the GitHub space linked below.

Support the Project

You can contribute to the project by visiting the space on GitHub at https://github.com/BabDev/Podcast-Manager and report bugs, provide patches for known issues, suggest new improvements, or download a working copy of the Git repository.  As well, translations are being accepted for Podcast Manager.  As part of the Open Translators initiative, Podcast Manager is listed on Transifex to accept community translations.

Suite Download

Download the newest posted release from the Latest Releases listing. Don't see this specific release listed? Check the Archived Releases listing for all of the installation packages that are available.