Extension Updates

Tweet Display Back 3.0 Beta Released

Tweet Display Back 3.0 Beta, a preview of the forthcoming 3.0 release series, has been released today and is now available for download.  This is a Beta level release which supports Joomla! 2.5 and Joomla! 3.0 ONLY; support for earlier versions of Joomla! has been discontinued.  Because this package is a BETA level package, it is NOT intended for use on production sites.

Where's 2.2!?

While working on 2.2, the scope of change within the code to improve the user experience became so great that the major version number (2 to 3) needed to change to properly reflect this.

Changes since 2.1

The biggest change with the 3.0 release series is that Joomla! support for versions earlier than 2.5 has been removed.  This allows for future development to focus solely on compatibility with current code and make use of new Joomla! Platform features.  Changes that have been made thus far in this release series:

  • Refactored helper class to follow OOP development pattern versus static helper methods
  • Refactored cache logic, making the annoying "user reached API limit" message a rare occurance
  • Removed support for versions of Joomla! earlier than 2.5
  • Removed JElement classes (supporting Joomla! 1.5)
  • Removed Joomla Color Picker extension in favor of the Joomla! Platform's color selection field
  • Removed internal relative date processing in favor of the equivalent Joomla! Platform code
  • Improved version notification field to add support for checking Joomla! version compatibility
  • Added support for showing version updates for all stability levels
  • Added support for displaying a user's favorited tweets
  • Added support for additional PHP connectors via Joomla's HTTP Platform package, replacing the previous internal logic
  • Resolved numerous bug reports


Tweet Display Back has a unique team of contributors.  Contributions have come in the form of provided code, translations, or external products.  I'd like to thank Open Translators for contributing the additional translations that are available in the module, enhancing international support.  Next, I'd like to thank Jurian Even of Twentronix for helping develop version 2.0 and implementing the filtering feature.  Lastly, the version check code is based on that found in the Construct Template Framework developed by Matt Thomas.

Future Development

As previously announced, future development for Tweet Display Back has shifted to only supporting Joomla! 2.5 and beyond.  Earlier versions of Joomla! are no longer supported..  The 3.0 series of Tweet Display Back will use new features introduced into the Joomla! Platform that will require Joomla! 2.5 or newer.  Also, lessening the support requirements for new versions means that additional features can be added without needing to be compatible with multiple versions of Joomla! and its supporting code (such as MooTools).

Development is driven by user request and API support.  If the Twitter API or Joomla! Platform can support the request, and it is a logical inclusion in this module, then it will more than likely be included in a future release.  Links with additional information about requesting or contributing features can be found in the documentation linked below.

Documentation & Support

As always, further information about the module is available in the Tweet Display Back section of the site, including information about the module's parameters, available translations, FAQ's, and more! Be sure to check out the Tutorials as well with tips on optimizing your module configuration and customizing the module's templates.


As of this release, Tweet Display Back is distributed in a total of twelve languages.  If you would like to update an existing translation or add a new translation, you may do so by visiting the project page on Transifex.

Download & Upgrade

As this is an BETA level release, users wishing to download it can do so from the Latest Releases listing in the Developer Releases section. The built in version check will show this as the latest version, and until released as stable, 3.0 releases will not be available via the Joomla! core update system.