Extension Updates

Podcast Manager 2.1 Release Candidate Released

The Podcast Manager 2.1 Release Candidate has been released today and is now available for download.  This is the release candidate of the Podcast Manager 2.1 release series and is considered feature complete and ready for release, however additional testing is requested prior to declaring this series stable.  With this release, the minimum supported version of Joomla! is 2.5.6, including all 3.x releases, and PHP 5.3 is required.

Changes since 2.0

Podcast Manager 2.1 has seen some changes to improve performance, add compatibility for both Joomla! 2.5 and 3.x, and introduced a new feature to allow statistics tracking via a third party service. The change list includes

    • Support Changes for Podcast Manager 2.1
      • Support for PHP 5.2 has been removed; PHP 5.3 is required to use Podcast Manager
      • The minimum supported version of Joomla! is 2.5.6
    • New Features
      • Ability to track statistics using the Blubrry and Podtrac services
      • Support for Joomla! 3.1 Tags
    • Bug Fixes
      • Possible to display podcast description twice in the feed listing module
      • Helper class not registered in feed listing module
      • Display podcast title when displaying the media player
      • Fixed link generation in feed link module
      • Unescaped filename in cookie breaks JavaScript (#85)
      • Missing translation strings added (#87)
    • Miscellaneous Changes
      • MediaElement.JS updated to 2.12.0
      • getID3 Library updated to 1.9.6
      • Allow layout overrides for feed link module
      • Native layouts for Joomla! 3.x Isis template (enabled by default on install)
      • Ensure getID3 library is present before parsing (#84)
      • Move all template media to the site /media folder and use Joomla! API for loading (allows overrides at template level)

Supports Joomla! 2.5.6 and newer

This release of Podcast Manager is available for Joomla! 2.5.6 and newer, including all 3.x releases.  Earlier versions of Joomla!, including earlier releases in the 2.5 series, are not supported due to the use of new API features and security vulnerabilities affecting early 2.5 releases.

Upgrade from Previous Releases

Users of Podcast Manager who are running Joomla! 2.5.6 or later will be able to upgrade immediately using either the Live Update button within the backend control panel or using Joomla's built in update system.

Need Additional Support?

Documentation about Podcast Manager is available on this site in the Podcast Manager section.  This area includes information about the suite, a description of the various configuration options, a method to subscribe for e-mail updates, and tutorials on various functions.  If you don't see something here that you think would be beneficial for all users, feel free to Contact Me with your suggestion.

Future Development

At this moment, a roadmap for future releases has not been planned aside from general maintenance. As always, features can be requested for inclusion in the project, which will be considered based on their applicable use cases.

Support the Project

You can contribute to the project by visiting the space on GitHub at https://github.com/BabDev/Podcast-Manager and report bugs, provide patches for known issues, suggest new improvements, or download a working copy of the Git repository.  As well, translations are being accepted for Podcast Manager.  As part of the Open Translators initiative, Podcast Manager is listed on Transifex to accept community translations.

Suite Download

Download the newest posted release from the Latest Releases listing. Don't see this specific release listed? Check the Archived Releases listing for all of the installation packages that are available.