Extension Updates

2014 Support Update

Things have been really quiet here for the last year with regards to extension updates, and for that I'd like to apologize. However, the quietness does not mean that support for the extensions has ended. Development has continued on the existing extensions and new code has been written, and 2015 looks to bring new releases (finally) and new products.

Joomla! 2.5 Support

I recently helped push out the final Joomla! 2.5 release and Joomla! will be ending support for that platform on December 31, 2014. Generally, I end support for Joomla! versions as they have support ended, but with the lack of updates this year, every Joomla! release from 2.5.6 to today (including the entire 3.x series) is supported in the existing code; both the stable releases from last year and the current development code. In the next releases of Podcast Manager and Tweet Display Back, Joomla! 2.5 will be supported, but these will be the final minor releases to include this support.

Podcast Manager 2.2 and Tweet Display Back 3.1 have been in testing for some time and have had general code updates throughout the year. Both are tested and working on Joomla! 2.5 and the 3.x series and there is no reason at this point to remove that support from a working code base. I'll be doing some final testing and reviewing of some known issues, especially in Podcast Manager, before issuing the new releases. My plan as of right now is to start work on Podcast Manager 3.0 and Tweet Display Back 3.2 soon after the next releases of those extensions, and both of those versions will drop support for Joomla! releases older than Joomla! 3.4 at a minimum. Much of that will depend on the development timeframe for the releases and Joomla's own release schedule when the release time comes up. Ending the older version support will let me clean up my own code some, including some known error messages that display with error reporting turned on in both Joomla! 2.5 and 3.x.

As for Yet Another Social Plugin, I've been running a redesigned version of that code, optimized for Joomla! 3, on my own site and the Joomla! Developer Network for some time with generally better results. A new version of that will come soon but will only support Joomla! 3.

Joomla! 2.5 to 3.x Migrations

I've aimed to write my extensions so that sites can update from Joomla! 2.5 to 3.x without any major hassle. In Tweet Display Back, this is completely possible to do as the only version workaround deals with displaying the module's update check in the Module Manager. For Podcast Manager, this is a little more extensive because of how I'm installing 3.x native layouts and adding support for 3.x features (the last stable release supports Joomla's tagging system and the current development code supports Content Versioning as well); this is an area that needs a little bit of improvement to make sure the migration is as efficient as possible. Look for extended notes on this with the Podcast Manager 2.2 release.

BabDev's Future

In 2015, I truly hope to get back to spending more time focusing in on some of my own projects, including the already available extensions here. I've also got some ideas floating around for new extensions based on other projects I've been working on this year and feedback I've gotten from different people on different ideas. I've also got some new code for developers usable both within the context of a Joomla! installation and generally in any PHP based project that's been formally tagged as stable but has not yet had a proper release, look for news on that early in 2015.